Register
Email: Password:
Forum » Hoverbike fail

Hoverbike fail

Nihil 6 years ago
Hello there, long time no see.
I see Ville is not going to give any update to game but im not asking for that.

My problem seems to be mean and evil because whenever I use hoverbike it does strange thing:
Werivar mod: Either Mk1 or Mk2 hoverbikes are usable, buildable but when I use the keycard and get into it the screen just goes to top-left corner of map and cant move it. I barely managed to drive there and the screen wont move, it goes back to normal when I exit the bike.
I tested it on Vanilla: The same thing happen except I am ejected from hoverbike very fast, In hermit map it was like quick look for egde of the map.

Can anyone help me with this? Got xp sp3, newest directx and I dont have any clue what it can be
#
E_net4 6 years ago
The "camera on top-left on hoverbike" is a known problem with the latest core version of Notrium. And only an update could fix it, I think.

Also, welcome to the forums. Enjoy your stay.
#
Nihil 6 years ago
Oh noes

Well, thats the big fail, I was hoping that I just overlooked something in files but it is not I see...

[ot]I was on forums before on Monkkonen with name Proso I think[/ot]
#
Venom31 6 years ago
I think you'll have to use previous version for some time if you like to use those Hovers.
#
Nihil 6 years ago
Uhh, if not only so much bug fixes etc

Well, maybe Ville will pour his blessing over the game and us and fix this one last bug
Or maybe not

EDIT: mmmkey, where can I find older versions of notrium? And whats the verion number of one without hoverbike problem?
Its also affecting Wazzal 2 mod not mentioning it runs slow but its annoying a bit on planets...
#
Venom31 6 years ago
"Nihil" said:
where can I find older versions of notrium? And whats the verion number of one without hoverbike problem?
The one before going to .NET was v1.341. It also seems to be a bit faster working. I'm not quite sure why . It may be still available at harwe's profile (look at the link below his signature).
#
Nihil 6 years ago
1.3.4.1? Uhh... I already have that version from the download from this site
It appears to be last version in readme changelog.
I am confused now
#
Venom31 6 years ago
It's been last for quite some time until Ville decided to revisit Notrium code. Going to .NET allowed to correct some bugs, but for me, 1.341 is still the best version...
1.345 is on .NET and is more recent, besides has a nifty Driftmoon ad in its launcher.

P.S. Who cares about changing the readme changelog, huh?
#
Nihil 6 years ago
Huh, and I was afraid I will miss some interesting changes, well I will try older notrium, maybe will get fun ^_^
#
harwe 6 years ago
Oh damn, I totally didn't know that there was a newer version of Notrium... Time to mirror that one too!
#
Nihil 6 years ago
Pleashe: Leave that version too :3

Probably Ville is too busy with Driftmoon so I doubt there will be new version.
#
ville 6 years ago
Yes, I'm a bit too busy with Driftmoon to fix Notrium. Sorry about that really. I should probably release the source code so somebody else could fix it...
#
MageKing17 6 years ago
"ville" said:
I should probably release the source code so somebody else could fix it...
#
Narvius 6 years ago
"MageKing17" said:
"ville" said:
I should probably release the source code so somebody else could fix it...
Indeed.
#
Sebine 5 years ago
I don't suppose there's a way to tell us how to fix it ourselves?
If that's possible...
#
E_net4 5 years ago
"Sebine" said:
I don't suppose there's a way to tell us how to fix it ourselves?
If that's possible...
I would say it isn't.
#
Sebine 5 years ago
"E_net4" said:
"Sebine" said:
I don't suppose there's a way to tell us how to fix it ourselves?
If that's possible...
I would say it isn't.
Oh well, guess I'll make due without it..
thanks though
#
YinYin Falcon 4 years ago
I have very recently run into this annoying problem myself and even downloaded the older version just to drive that hoverbike once again. But I have also coded myself a simple solution:

inside the hoverbike creature:
a new timed block (100 msec)
if creature carries another creature
attach camera to this creature forever

voila
that way it works in both new and old version

Edited 4 years ago
#
Anonymous1157 4 years ago
I'd release that script if I were you. We've got two script-heavy (-abusing?) mods in development right now, and I'm sure they'd gladly implement a bug workaround like this one. (Not that they couldn't reproduce your script from the description. But why duplicate work?)
#
YinYin Falcon 4 years ago
  100;//interval in milliseconds
begin_conditions;
34;//condition
0.000000;//condition parameter0
0.000000;//condition parameter1
end_conditions;
begin_effects;
49;//effect number
0.000000;//parameter1
0.000000;//parameter2
-1.000000;//parameter3
0.000000;//parameter4
end_effects;
end_timed_block;
#
N17ForgotHisPassAgain (guest) 4 years ago
Cheers for this Yin, I'm not that far off from vehicles, so I'll definitely be bearing this one in mind.

Script Abusing? Guilty, I'm about sixteen scripts from beating the next two closest competitors combined for total script count, and that's ignoring the creature and plot object script blocks.
#
Random Guest (guest) 3 years ago
YinYin Falcon said:
  100;//interval in milliseconds
begin_conditions;
34;//condition
0.000000;//condition parameter0
0.000000;//condition parameter1
end_conditions;
begin_effects;
49;//effect number
0.000000;//parameter1
0.000000;//parameter2
-1.000000;//parameter3
0.000000;//parameter4
end_effects;
end_timed_block;

I added this to my creature.dat and it worked but after I get off the bike camera is still focused on the bike.
#
Random Guest (guest) 3 years ago
Random Guest (guest) said:

I added this to my creature.dat and it worked but after I get off the bike camera is still focused on the bike.
Nevermind I managed to fix it by changing effect's parameter3 from -1 to 200.
#
Notrim Player (guest) 3 years ago
Random Guest (guest) said:
YinYin Falcon said:
 100;//interval in milliseconds begin_conditions; 34;//condition 0.000000;//condition parameter0 0.000000;//condition parameter1 end_conditions; begin_effects; 49;//effect number 0.000000;//parameter1 0.000000;//parameter2 -1.000000;//parameter3 0.000000;//parameter4 end_effects; end_timed_block;
I added this to my creature.dat and it worked but after I get off the bike camera is still focused on the bike.

can u please say where exactly in the list u have to put the script and what to change mby post the script u used and tell me after what names or numbers i gotta put it cuz i tried and the game gave me an error and it wouldnt start clearly i did something wrong in the creature data file please help me i do want to use the hooverbike it would make the game a lot more fun (ive beaten the game in every single way posible with all races and i never played on a difficutlty below hard cuz the game is too simple) thank you
#
Forum » Hoverbike fail

Post Reply


Your email:
Your name: