Register
Email: Password:
Forum » Notrium modding questions/answers
  • « previous
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 31
  • » next
  • Notrium modding questions/answers

    Crazy 10 years ago
    I'm pretty sure it has something to do with the races.dat...
    #
    MageKing17 10 years ago
    There's an effect that does it. The description is fairly straightforward... something like "hide x bar" or "disable x bar."
    #
    Inane 10 years ago
    My plot object is being stupid...

    It seems to choose a random ammount of effects from the list before not doing the rest

    The teleporter is supposed to reset the character to normal, but no-o-o-o, it has to do things from just changing the control type, to transporting, changing inventory, and enabling the opening of inventory.

    Here's the entry:
    Landing bay;//name---------------------------------------
    118;//identifier
    -1;//map type to place to -1=any map 0=> type from areas.dat
    0;//plot_object class
    99;//object definition number
    0;//number of objects to be placed
    -1;//location type, 0=random, 1=distance min(parameter1) max(parameter2) from player start, 2=distance min(parameter1) max(parameter2) from object parameter0, 3=coordinates [parameter0, parameter1] (0=min, 1=max) vary location=parameter2
    0.000000;//location parameter0
    0.000000;//location parameter1
    0.000000;//location parameter2
    0;//show on radar 0=does not show, 1=show on scanner, 2=show even without scanner
    20;//particle to shown on radar
    none;//radiate sound
    -1.000000;//time to delete object in milliseconds, -1=don't delete
    0;//trigger event by 0=player click, 1=player near, 2=near or click, 3=map creation (try to avoid any creature specific effects when using this, also does not check conditions), 4=interval parameter1
    0;//trigger event parameter1
    1;//show help text for conditions
    begin_effects_block;
    none;//event text
    none;//sound, none for nothing
    2;//vanishes after event, 0=no, but cannot be reused, 1=vanishes, 2=no, and can be reused
    begin_conditions;
    end_conditions;
    begin_effects;
    56;
    -1.000000;
    0.000000;
    0.000000;
    0.000000;
    34;//effect number
    -1.000000;//parameter1
    0.000000;//parameter2
    0.000000;//parameter3
    0.000000;//parameter4
    4;//effect number
    1000.000000;//parameter1
    1.000000;//parameter2
    0.000000;//parameter3
    0.000000;//parameter4
    58;
    1.000000;
    0.000000;
    0.000000;
    0.000000;
    60;
    1.000000;
    0.000000;
    0.000000;
    0.000000;
    21;//effect number
    34.00000;//parameter1
    116.00000;//parameter2
    1.000000;//parameter3
    0.000000;//parameter4
    52;//en
    0.000000;
    0.000000;
    0.000000;
    0.000000;
    end_effects;
    end_effects_block;


    What am I doing wrong? How the hell do I get all of the effects to effect?
    #
    Crazy 10 years ago
    well... the only thing out of order i noticed is the //location type being -1, which is not listed.

    Also, could it be because you have not added // to the end of effects? not sure if that matters, but... y'know...

    Also, that //en looks weird, but im pretty sure that doesen't matter...

    Yeah...

    That didn't help at all, right?

    oh well...
    #
    Pete 10 years ago
    Now MY plot object is being stupid...

    I use item to get teleported to area, them change to other race using a plot object there and it works fine. Them Ido JUST the same, only this time I use the plot object with the same effect, but this time it crashes. Here is the debug...

    Starting Frame
    Starting Render Map
    Starting Handle Item List
    Finished Handle Item List
    Starting Calculate Scripts
    Finished Calculate Scripts
    Starting Player Controls
    Finished Player Controls
    Starting AI
    Finished AI
    Starting Calculate Creatures
    Finished Calculate Creatures
    Starting Calculate Bullets
    Finished Calculate Bullets
    Starting Calculate Particles
    Finished Calculate Particles
    Starting Calculate Items


    If you need to know more, just tell and Ill post it.

    EDIT: Sorry Inane, no idea. I had to do it this way... 2 plot object and the starting teleporter to get it working just right.

    EDIT: EDIT:

    teleporter;//name
    12;//id
    -1;//map type to place to
    0;//plot object class
    16;//plot object def. number, NOT -1
    0;//number of objects to be placed
    0;//location type
    0;//parameter0
    0;//parameter1
    0;//parameter2
    0;//show on radar
    2;//particle shown on radar
    none;//radiate sound, none for nothing
    0;//time to delete object in ms
    0;//trigger event by
    0;//parameter1
    0;//show help texts for conditions
    begin_effects_block;
    end_effects_block;
    change to crosshair;//name
    13;//id
    -1;//map type to place to
    0;//plot object class
    16;//plot object def. number, NOT -1
    0;//number of objects to be placed
    0;//location type
    0;//parameter0
    0;//parameter1
    0;//parameter2
    0;//show on radar
    -1;//particle shown on radar
    none;//radiate sound, none for nothing
    0;//time to delete object in ms
    1;//trigger event by
    0;//parameter1
    0;//show help texts for conditions
    begin_effects_block;
    none;//event text
    none;//sound, none for nothing
    2;//vanishes after event
    begin_conditions;
    end_conditions;
    begin_effects;
    34;//effect number
    1;//parameter1
    0;//parameter2
    0;//parameter3
    0;//parameter4
    55;//effect number
    0;//parameter1
    0;//parameter2
    0;//parameter3
    0;//parameter4
    end_effects;
    end_effects_block;
    Evelator.;//name
    22;//id
    -1;//map type to place to
    0;//plot object class
    27;//plot object def. number, NOT -1
    0;//number of objects to be placed
    0;//location type
    0.000000;//parameter0
    0.000000;//parameter1
    0.000000;//parameter2
    0;//show on radar
    0;//particle shown on radar
    none;//radiate sound, none for nothing
    -1.000000;//time to delete object in ms
    0;//trigger event by
    0;//parameter1
    1;//show help texts for conditions
    begin_effects_block;
    You step into the evelator and have a look at the control panel.;//event text
    none;//sound, none for nothing
    2;//vanishes after event
    begin_conditions;
    24;//use condition number
    7;//parameter0
    1;//parameter1
    end_conditions;
    begin_effects;
    21;//effect number
    7;//parameter1
    12;//parameter2
    0;//parameter3
    0;//parameter4
    end_effects;
    end_effects_block;


    This could help you solve my problem...
    #
    Pete 10 years ago
    Help! I really got to fix it!
    #
    Lochen 10 years ago
    Well, if anyone could help as of right now I'm sure they would. I am no longer playing notrium, otherwise I would try your code.
    #
    MageKing17 10 years ago
    I see a BIG problem...
    "Pete" said:
    teleporter;//name
    12;//id
    -1;//map type to place to
    0;//plot object class
    16;//plot object def. number, NOT -1
    0;//number of objects to be placed
    0;//location type
    0;//parameter0
    0;//parameter1
    0;//parameter2
    0;//show on radar
    2;//particle shown on radar
    none;//radiate sound, none for nothing
    0;//time to delete object in ms
    0;//trigger event by
    0;//parameter1
    0;//show help texts for conditions
    begin_effects_block;
    end_effects_block;
    change to crosshair;//name
    13;//id
    -1;//map type to place to
    0;//plot object class
    16;//plot object def. number, NOT -1
    0;//number of objects to be placed
    0;//location type
    0;//parameter0
    0;//parameter1
    0;//parameter2
    0;//show on radar
    -1;//particle shown on radar
    none;//radiate sound, none for nothing
    0;//time to delete object in ms
    1;//trigger event by
    0;//parameter1
    0;//show help texts for conditions
    begin_effects_block;
    none;//event text
    none;//sound, none for nothing
    2;//vanishes after event
    begin_conditions;
    end_conditions;
    begin_effects;
    34;//effect number
    1;//parameter1
    0;//parameter2
    0;//parameter3
    0;//parameter4
    55;//effect number
    0;//parameter1
    0;//parameter2
    0;//parameter3
    0;//parameter4
    end_effects;
    end_effects_block;
    Evelator.;//name
    22;//id
    -1;//map type to place to
    0;//plot object class
    27;//plot object def. number, NOT -1
    0;//number of objects to be placed
    0;//location type
    0.000000;//parameter0
    0.000000;//parameter1
    0.000000;//parameter2
    0;//show on radar
    0;//particle shown on radar
    none;//radiate sound, none for nothing
    -1.000000;//time to delete object in ms
    0;//trigger event by
    0;//parameter1
    1;//show help texts for conditions
    begin_effects_block;
    You step into the evelator and have a look at the control panel.;//event text
    none;//sound, none for nothing
    2;//vanishes after event
    begin_conditions;
    24;//use condition number
    7;//parameter0
    1;//parameter1
    end_conditions;
    begin_effects;
    21;//effect number
    7;//parameter1
    12;//parameter2
    0;//parameter3
    0;//parameter4
    end_effects;
    end_effects_block;
    You have three effects blocks. One ends instantly, the other two have the actual effects. It's screwing up the game engine, no doubt.
    #
    Pete 10 years ago
    What do you mean? I tried removing the empty one but it just caused a LOT of strange stuff.
    #
    MageKing17 10 years ago
    I mean you should only have ONE. It should all go where the empty one is now. When you removed it, you messed up the file structure and the game really hated you. While it's empty like it is now, it's still messing up the structure, but in a different way.
    #
    Pete 10 years ago
    Hmm, I really got to use at least TWO plot objects. One for start and the other one as target. And the third one is there because I just didnt though of placing it in the first one...

    EDIT You know what? I draw a picture of the placement of the plot objects...



    EDIT EDIT EDIT: It works kidna like menu...
    #
    Darkdude 10 years ago
    How do you make something so that walking off the top end makes you reappear at the bottom?
    #
    Rezan 10 years ago
    I might be mistaken but I think that's the wrap effect. I was reading through some modding tips and stuff the other day and came across "wrap" or "wrapping", can't quite remember which. Anyways, it said that it was new and could make it so you reappear on the other side of the map by walking down the opposite direction.

    This might not help you though, if you don't want it to work both ways.
    #
    Darkdude 10 years ago
    I found it in the areas.dat but it was labelled as wrapping so i didnt know until you said that
    #
    Rezan 10 years ago
    Glad to have been of help =D
    #
    Pete 10 years ago
    EDIT! EDIT!

    New problem.



    Those green thing are radiation liquids. The problem is, they should be thansparent, that one in the corner is added to show you how it should look. Im using .png and Gimp.
    #
    Darkdude 10 years ago
    what about the effect that trees have? they get transparent when you get close
    #
    Grim Reaper 10 years ago
    "darkdude" said:
    what about the effect that trees have? they get transparent when you get close
    That's because they're on a layer above the one where the player is.
    #
    Pete 10 years ago
    They are supposed to be transparent at any time. Strange thing is, it seemed to work in the map editor.
    #
    Darkdude 10 years ago
    Well have you tried putting the fog one layer above the player then?
    #
    Pete 10 years ago
    BTW, Is it possible to have always-thansparent plot object?
    #
    Darkdude 10 years ago
    I have a problem, if i change the name of the folder in a mod like Default to Whatever then all the graphics in the game are screwed around. Why is this?
    #
    Grim Reaper 10 years ago
    "darkdude" said:
    I have a problem, if i change the name of the folder in a mod like Default to Whatever then all the graphics in the game are screwed around. Why is this?
    Check if there's a folder with the same name as the one you changed and rename that one, too (i.e. if you renamed the folder Agrajag to, say, Slartibartfast, check if there is a folder named Agrajag in the GFX folder. If there is, you must rename that one, too, to Slartibartfast).
    #
    Darkdude 10 years ago
    that fixed it thanks
    #
    Pete 10 years ago
    is there any way to turn this:

    into a picture useful in game?
    #
    >.>...<.< 10 years ago
    umm I need some help, just a minor tweak in game, I want to create a weapon that shoots a long green beam and does high damage with 75 energy drain per shot but around -450 or so for the hit effect damage, I seemed to find more help looking at the datafiles themselves than the FAQ, could someone explain to me in lamen's how to do this?
    -------------------------------------------------------------------------------------
    I was also wondering about implementing pictures for inven shots and how to make a high damage pistol with slow fire rate(slower and higher than VC pistol)
    #
    Grim Reaper 10 years ago
    "Pete" said:
    is there any way to turn this:

    into a picture useful in game?
    Is it not usefull already?

    I mean, it seems like you could use it as a plot object or an item image...

    And since it's a .jpg, you don't have to make transparency fer it, either.

    ...unless you don't want the near-black things to show as near-black, but transparent-something.
    #
    Darkdude 10 years ago
    maybe you could edit it so it could be a variant on the glass marble
    #
    Pete 10 years ago
    I want it to work. This way (I believe) it would have an ugly blck border.
    #
    MageKing17 10 years ago
    Why don't you try it and see for yourself? The results might surprise you.
    #
    Inane 10 years ago
    I was bored .


    Ingame:


    Texture:
    #
    Grim Reaper 10 years ago
    So you edited it?

    Did you even TRY it without editing?
    #
    Inane 10 years ago
    "Grim Reaper" said:
    Did you even TRY it without editing?

    Why would I do that? It would have a thick black square surrounding it.
    #
    Grim Reaper 10 years ago
    Strange... In the previous versions, the colour black was used as a background colour for JPEG-type images...

    And yes, I tested it, it DOES show up with a black border thingy if it isn't modified.
    #
    Pete 10 years ago
    Well, thanks Inane. Thats just good enough.
    #
    Forum » Notrium modding questions/answers
  • « previous
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 31
  • » next
  • Post Reply


    Your email:
    Your name: